五花八门

Dell Networking N4000(下)交换机基本配置命令实例

liaoya · 9月17日 · 2020年 · · 98次已读

前置说明:
请使用Console线连接到交换机的Console接口进行初始化配置,如果遇到问题,请使用 ? 协助。若是配置过程中遇到错误,请特别注意您命令是在什么模式下输入命令。
此文档为个人整理,仅供参考,请以戴尔官网用户手册为准。
“>” 为用户模式, 此模式为刚Console登录交换机的模式,只能使用大部分Show命令。
“#”为特权模式,此模式需要从用户 模式下使用enable命令进入
(config)# 为全局配置模式,很多配置需要在此模式下输入
(config-if)#或者(config-vlan)# 为端口模式,可以对端口进行一些操作,例如IP配置,端口的Up和Down。

//保存交换机配置
console>en
console#write //保存交换机配置,请在完成必要配置之后,记得使用此命令保存,否则交换机重启后没保存的配置将丢失。

//修改交换机名称,配置用户名和密码,请务必牢记并尽量写在安全的地方
console>en
console#configure
console(config)#username admin password admin123 privilege 15
console(config)#hostname ABC //将交换机改名为ABC
console(config)#end
console#write

//端口配置portfast(连接到此交换机的电脑获取DHCP非常慢,或者很慢才能够识别网络,可以考虑配置)
console#configure
console(config)#interface gi1/0/1 //如果对多个端口同时配置,可以使用interface range gi1/0/1-12
console(config-if)# spanning-tree portfast
console(config-if)#exit
console(config)#end
console#write

//配置管理Vlan1 ip地址(可以从任何一个在Vlan1的网口来管理)
console#configure
console(config)#int vlan 1
console(config-if)#ip address 192.168.1.1 255.255.255.0
console(config-if)#exit
console(config)#ip default-gateway 192.168.1.254 (假设网关地址为192.168.1.254)
console(config)#end
console#write

//配置管理接口(OOB接口)的ip地址(不是所有交换机都有这个管理口,此管理网口通常和Console接口挨在一起,只有网线连接到这个网口才可以使用这个IP管理,此IP不能与Vlan1的IP完全一样,建议设置Vlan1 IP同一个网段)
console#configure
console(config)#interface out-of-band
console(config-if)#ip address 192.168.1.2 255.255.255.0
console(config-if)#exit
console(config)#ip default-gateway 192.168.1.254 (假设网关地址为192.168.1.254)
console(config)#end
console#write

//连接ISCSI存储时一般建议配置巨帧和流控
console>enable
console#configure
console(config)#system jumbo mtu 9216 -------------开巨帧
console(config)#flowcontrol receive on -------------开流控
console(config)#end
console#write

//删除交换机配置文件(交换机所有配置将丢失,请确认不需要配置了或者已经有备份配置文件)
console>enable
console#write //保存配置
console#delete startup-config //删除启动配置文件
Delete startup-config ? (y/n) y //y 确认删除
console# reload //重启交换机
Are you sure you want to reload the stack? (y/n) y //y 确认重启

//DHCP 服务器配置范例:
console#configure
console(config)#service dhcp //启用DHCP服务
console(config)#ip dhcp pool Engineering //定义地址池名称
console(config-dhcp-pool)#network 192.168.5.0 255.255.255.0 //指定地址池
console(config-dhcp-pool)#default-router 192.168.5.1 //指定网关
console(config-dhcp-pool)#dns-server 192.168.5.10 //指定DNS服务器
console(config-dhcp-pool)#dns-server 192.168.5.11
console(config-dhcp-pool)#exit
console(config)#ip dhcp excluded-address 192.168.5.1 192.168.5.20 //指定排除的地址段(批量写法),不会分配给client,前面是最小的IP,后面是最大的IP
console(config)#ip dhcp excluded-address 192.168.5.100 //指定排除的地址段(单个IP写法)
console(config)#exit
console#copy run start //保存配置,也可以用write

console(config)#interface vlan 100 //需要设置Vlan 100的IP地址(假设这个DHCP地址池192.168.5.X/24是给Vlan100的)
console(config-if)#ip address 192.168.5.1 255.255.255.0
console(config-if)#no shutdown
console(config)#end
console#write

console(config)#interface range gi1/0/1-12 //然后设置gi1/0/1-12端口属于Vlan100,能够自动获取DHCP Server提供的IP地址:
console(config-if)#switchport mode access
console(config-if)#switchport access vlan 100
console(config-if)#spanning-tree portfast
console(config-if)#no shutdown
console(config-if)#end
console#write //保存配置

经过以上配置,gi1/0/1-12这12个在Vlan100的端口接上设备时,就都能够获得DHCP地址了

//添加、刪除vlan
console(config)#vlan 4,5-20 添加VLAN
console(config)#no vlan 100,200,300 刪除VLAN

=>配置Access口,将存放在某个vlan中(接PC或伺服器)
console(config)#interface range gi1/0/5-10 or ethernet /g5-1/g10
console(config-if)#switchport mode access
console(config-if)#switchport access vlan 10

=>配置Trunk(接交换机或配置子界面的网络设备)
console(config)#interface range gi1/0/5-10 or ethernet 1/g48
console(config-if)#switchport mode trunk
console(config-if)#switchport trunk allowed vlan add 1,2,5-8

=>配置VLAN IP
console(config)#interface vlan 10
console(config-if-vlan10)#ip address 192.168.100.24 255.255.255.0

=>VLAN间路由(实现不同VLAN间通信)
console(config)#ip routing(或routing)
console(config)#interface vlan 20
console(config-if-vlan20)#ip address 192.168.200.24 255.255.255.0
*不同Vlan间的PC互访,请在各自PC上配置正确的网关地址!网关地址一般为各自vlan端口的SVI地址

//恢复出厂配置
请操作前先备份现有配置到本地电脑,或者确定不需要保存!
Console#delete startup-configure ///删除启动配置文件
然后按y 确认,
Console#reload //重启交换机,注意重启前不要执行write 保存命令。

//关闭DCB功能
Console(config)#no dcb enable //关闭无损以太网功能
Console(config)#exit
Console#write //保存配置

0 条回应